Stock value calculator update 2

Several enhancements made.

Android: https://market.android.com/details?id=com.inoapp.sa4a
IOS: http://itunes.apple.com/us/app/stock-analyst-pro/id469837612?mt=8

Advertisements
Stock value calculator update 2

How to install IIS 5.1 and ASP.NET 3.5

How to install IIS:

It’s pretty simple to install IIS: Control Panel \ Add or Remove Programs \ Add/Remove Windows Components \ check on IIS. 
Here is the list of IIS versions on compatible Windows:

Since I have XP Pro, IIS 5.1 is the only IIS version I can get. If you want IIS 7, get Vista or Server 2008.

How to install ASP.NET:

The easiest way is using Free Microsoft Web Platform Installer. Download here. Notes: Web Platform Installer can install IIS also.

  •  Choose .NET Framework 3.5 Service Pack 1. 
  •  Choose  Visual Web Developer 2008 Express Edition SP1.
  • Open command prompt, type following commands to register ASP.NET with IIS:
cd  C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
aspnet_regiis.exe -i
  • Open Control Panel \  Administrative Tools \ Internet Information Services. Right-click on Web Sites under your server choose Properties. Choose ASP.NET tab. Select ASP.NET version 2.0.50727.

Notes:  

  •  ASP.NET 3.5 is included in .NET Framework 3.5 Service Pack 1. You cannot intall ASP.NET separately.
  •  ASP.NET 3.0 and 3.5 are ASP.NET 2.0 extensions. Installing ASP.NET 2.0 is all you need. That’s the reason why in IIS ASP.NET tab there is no 3.0 & 3.5 selection. 
  • If you don’t register ASP.NET, you will get “Server Application Unavailable” error while opening .aspx files and 2 following errors in pair in Event Viewer\Application:
Failed to execute request because the App-Domain could not be created. Error: 0x80131902 

Failed to initialize the AppDomain:/LM/W3SVC/1/ROOT
Exception: System.Configuration.ConfigurationErrorsException
Message: Exception of type 'System.Configuration.ConfigurationErrorsException' was thrown.
How to install IIS 5.1 and ASP.NET 3.5